hdu1520 Anniversary party(poj2342,树形dp)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7303 Accepted Submission(s): 3220


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests' ratings.

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output
  
  
5

Source

这题和poj2342是一样的,但是hdu的数据加强了,用poj2342AC的代码可能会超时, poj2342解析报告
这里用的方法有点不一样,但大概也都是一样的,只是加入了一些父子兄弟关系,也不是很难理解。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))

struct Tree
{
    int father;//父亲
    int child;//儿子
    int brother;//兄弟
    int Not;//不去party
    int TakeParty;//去party
    int MAX() {return TakeParty > Not ? TakeParty : Not;}//结构体调用函数省时间
    int init()//树清空
    {
        father = child = brother = Not = 0;
    }
}tree[6005];

void dfs(int idx)
{
    int child = tree[idx].child;
    while(child)//如果有孩子继续查
    {
        dfs(child);
        tree[idx].TakeParty += tree[child].Not;//如果idx去party,那么它的孩子就不能去
        tree[idx].Not += tree[child].MAX();//如果idx不去party,那么它的孩子可去可不去
        child = tree[child].brother;//查找其他孩子
    }
}

int main()
{
    int n,a,b;
    while(scanf("%d",&n)==1)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&tree[i].TakeParty);
            tree[i].init();
        }
        while(scanf("%d%d",&a,&b),a+b)//建树
        {
            tree[a].father = b;
            tree[a].brother = tree[b].child;
            tree[b].child = a;
        }
        for(int i=1; i<=n; i++)//查找
        {
            if(!tree[i].father)
            {
                dfs(i);
                printf("%d\n",tree[i].MAX());
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值