Intersection

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3624    Accepted Submission(s): 1372


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6216 6215 6214 6213 6212


一道数学题,求两个环相交的面积


答案是两个大圆相交的面积+两个小圆相交的面积-2×大圆和小圆的面积


ac代码如下:
#include <iostream>
#include <stdio.h>
#include <queue>
#include <stack>
#include <string>
#include <string.h>
#include <cmath>
#include <algorithm>

#define mem(a,b) memset(a,b,sizeof(a))
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r

using namespace std;
const double PI=acos(-1);

double x2,x3,y2,y3,d;

double area(double r,double R)
{
    d=sqrt((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2));
    if(r>R)
        swap(r,R);
    if (r+ R <= d)
        return 0;//相离
    else if (R - r >= d)
        return PI*r*r;//内含
    else {

        double a1 = acos((r*r + d*d - R*R) / (2.0*r*d));
        double a2 = acos((R*R + d*d - r*r) / (2.0*R*d));
        return (a1*r*r + a2*R*R - r*d*sin(a1));
    }//相交
}
int main()
{
    double r,R;

    int t;
    int cont=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&r,&R);
        if(r>R)
            swap(r,R);
        scanf("%lf%lf",&x3,&y3);
        scanf("%lf%lf",&x2,&y2);
        double ans=area(R,R)+area(r,r)-2*area(r,R);
        printf("Case #%d: %.6lf\n",++cont,ans);

    }

    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值