数字序列

题目描述 Description

给定一个长度为n的一个序列A1,A2,…,An,求序列中连续子序列的最大和。

例如:当输入为-5,3,5,7,-15,6,9,27,-36,10时,连续子序列6,9,27的和为42是最大值;而当序列变成-5,3,5,8,-15,6,9,27,-36,10时,连续子序列3,5,8,-15,6,9,27的和为43是最大值。

输入描述 Input Description

第一行为n (n≤1000),第二行为n个数,表示序列Ai(-10000≤Ai≤10000)。

输出描述 Output Description

一个数,表示连续子序列的最大和。

样例输入 Sample Input

10

-5 3 5 8 -15 6 9 27 -36 10

样例输出 Sample Output

43

数据范围及提示 Data Size & Hint

-10000≤Ai≤10000

n≤1000

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
	int Max=0,sum=0,s;
	int n;
	int i;
	scanf("%d", &n);
	for(i=0;i<n;i++)
	{
		scanf("%d", &s);
		sum+=s;
		if(Max<sum)
		{
			Max=sum;
		}
		if(sum<0)
		sum=0;
	}
	printf("%d\n",Max);
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值