1056 Mice and Rice

1056 Mice and Rice (25 分)
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N
​P
​​ programmers. Then every N
​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N
​G
​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N
​P
​​ and N
​G
​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N
​G
​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N
​P
​​ distinct non-negative numbers W
​i
​​ (i=0,⋯,N
​P
​​ −1) where each W
​i
​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N
​P
​​ −1 (assume that the programmers are numbered from 0 to N
​P
​​ −1). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
题意:
给出np只老鼠的质量,并给出他们的初始顺序,按这个初始顺序把这些老鼠按每ng只分为一组,最后不够ng只的也单独分为一组。对每组老鼠,选出他们中质量最大的1只晋级,这样晋级的老鼠数就等于该轮分组的组数。对这些晋级的老鼠再按上面的步骤每ng只分为一组进行比较,选出质量最大的一批继续晋级,这样直到最后只剩下一只老鼠,排名为1。把这些老鼠的排名按原输入的顺序输出。
思路:
1.结构体mouse,j=记录每只老鼠的质量和排名
定义队列,在算法过程中按顺序处理每轮的老鼠
2.计算数据(1)每轮比赛把老鼠分成的组数group:设当前轮的参数老鼠数有temp只,如果temp%ng为0,那么说明能够把老鼠完整划分,因此group=temp/ng;否则,说明最后会有少于ng只老鼠会单独分为一组,此时组数group=temp/ng+1
(2)由于每组晋级一只老鼠,因此当前轮晋级的总老鼠数等于group,且该轮未晋级的老鼠数排名为group+1

#include<cstdio>
#include<queue>
using namespace std;
const int maxn=1010;
struct mouse
{
	int weight;//质量
	int R;//排名 
	
} mouse[maxn];
int main()
{
	
	int np,ng,order;
	scanf("%d%d",&np,&ng);
	for(int i=0;i<np;i++)
	{
		scanf("%d",&mouse[i].weight);
	}
	queue<int> q;//定义一个队列
	for(int i=0;i<np;i++)
     {
     	scanf("%d",&order);//给出的顺序
		q.push(order);//按顺序把老鼠的标号入队
			
     }
     int temp=np,group;//temp为 当前轮的比赛总老鼠数,group为组数
	 while(q.size()!=1)
	 {
 		//计算group,即当前轮分为几组进行比赛
		 if(temp % ng==0) group=temp/ng;
		 else group=temp/ng+1;
		 //枚举每一组,选出该组老鼠中质量最大的
		 for(int i=0;i<group;i++)
		 {
 			int k=q.front();//k存放改组质量最大的老鼠的编号
			for(int j=0;j<ng;j++)
			{
				//在最后一组老鼠不足ng时起作用,退出循环
				if(i*ng+j>=temp)
				break;
				int front=q.front();//队首老鼠编号
				if(mouse[front].weight>mouse[k].weight) 
				{
					k=front;//找出质量最大的老鼠 
				}
				mouse[front].R=group+1;//该轮老鼠排名为group+1
				q.pop();//出队这只老鼠
				 
			} 
			q.push(k);//把胜利的老鼠晋级 
 			
 		 }
		  temp=group;//group只老鼠晋级,因此下轮总老鼠数为group
		   
 	 } 
 	 mouse[q.front()].R=1;//当队列中只剩一只老鼠时,令其排名为1
     //输出所以老鼠的信息
	 for(int i=0;i<np;i++) 
	 {
 		printf("%d",mouse[i].R);
 		if(i<np-1) printf(" ");
 	}
 	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值