1097 Deduplication on a Linked List

1097 Deduplication on a Linked List (25 分)
Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10
​5
​​ ) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next
where Address is the position of the node, Key is an integer of which absolute value is no more than 10
​4
​​ , and Next is the position of the next node.

Output Specification:
For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
题意:给出N个结点的地址address,数据域data以及指针域next,然后给出链表的首地址,要求去除链表上权值的绝对值相同的结点(只保留第一个),之后把未删除的结点按链表连接顺序输出,接着把被删除的结点也按原链表中的顺序输出。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100005;
const int table = 1000010;
struct Node {
    int address, data, next;
    int order;//结点在链表上的序号,无效结点为2maxn 
}node[maxn];
bool isExist[table] = {false};//绝对值是否已经出现
bool cmp(Node a, Node b) {
    return a.order < b.order;
}
int main() {
    memset(isExist, false, sizeof(isExist));//初始化isExist为未出现
    for(int i = 0; i < maxn; i++) {
        node[i].order = 2 * maxn;//表示初始时均为无效结点 
    }
    int n, begin, address;
    scanf("%d%d", &begin, &n);
    for(int i = 0; i < n; i++) {
        scanf("%d", &address);
        scanf("%d%d", &node[address].data, &node[address].next);
        node[address].address = address;
    }
    //未删除的有效结点个数和已删除的有效结点个数
    int countValid = 0, countRemoved = 0, p = begin;
    while(p != -1) {
        if(!isExist[abs(node[p].data)]) 
       
        {
            isExist[abs(node[p].data)] = true;//标记为已存在
            node[p].order = countValid++;//不删除,编号从0开始
        } else {
         
            node[p].order = maxn + countRemoved++;//被删除,编号从maxn开始
        }
        p = node[p].next;
    }
    sort(node, node + maxn, cmp);
    int count = countValid + countRemoved;//有效结点个数
    for(int i = 0; i < count; i++) {
        if(i != countValid - 1 && i != count - 1) {
            printf("%05d %d %05d\n",node[i].address, node[i].data, node[i + 1].address);
        } else {
            printf("%05d %d -1\n", node[i].address, node[i].data);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值