1020 Tree Traversals

1020 Tree Traversals (25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
题意:给出一颗二叉树的后序遍历和中序遍历,求这颗二叉树的层序遍历
在这里插入图片描述
理解上图的过程,这道题就好做了。

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=50;
struct node
{
	int data;
	node *lchild;
	node *rchild;
};
int pre[maxn],in[maxn],post[maxn];//先序,中序,后续
int n;//结点个数

//当前二叉树的后序序列区间为[postL,postR]
//中序序列区间为[inL,inR]
node *create(int postL, int postR, int inL, int inR)
{
	if(postL>postR)
	{
		return NULL;
	}
	node *root=new node;
	root->data=post[postR];
	int k;
	for(k=inL;k<=inR;k++)
	{
		if(in[k]==post[postR])
		break;
	}
	int numLeft=k-inL;
	root->lchild=create(postL,postL+numLeft-1,inL,k-1);
	root->rchild=create(postL+numLeft,postR-1,k+1,inR);
	return root;
} 
int num=0;
void BFS(node * root)
{
	queue<node*> q;//队列里存地址
	q.push(root);//根结点地址入队
	while(!q.empty()) 
	{
		node * now=q.front();//取出队首元素
		q.pop(); 
		printf("%d",now->data);//访问队首元素
		num++;
		if(num<n)
		printf(" ");
		if(now->lchild!=NULL)q.push(now->lchild);
		if(now->rchild!=NULL)q.push(now->rchild); 
	}
}
int main()
{
	scanf("%d", &n);
	for(int i=0;i<n;i++)
	{
		scanf("%d", &post[i]);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d", &in[i]);
	}
	node * root=create(0,n-1,0,n-1);
	BFS(root);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值