1034 Head of a Gang

1034 Head of a Gang (30 分)
One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time
where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:
For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 1:
2
AAA 3
GGG 3
Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 2:
0
题意:给出若干个人之间的通话长度(视为无向边),这些通话将他们分为若干组。每个组的总边权设为该组内所有通话的长度之和,而每个人的点权设为该人参与的通话长度之和。现在给定一个值K,只要一个组的总边权超过K,并满足成员人数超过2,则将该组视为“犯罪团伙”,而该组内点权最大的人视为头目。要求输出“犯罪团伙”的个数,并按头目姓名字典序从小到大的顺序输出每个“犯罪团伙”的头目姓名和成员人数。

#include<iostream>
#include<string>
#include<map>
using namespace std;
const int maxn=2010;//总人数
const int INF=100000000;//无穷大
map<int,string> intToString;//编号->姓名
map<string,int> stringToInt;//姓名->编号
map<string,int> Gang;//head->人数
int G[maxn][maxn]={0},weight[maxn]={0};//邻接矩阵G,点权weight
int n,k,numPerson=0;//边数n,下限k,总人数numPerson 
bool vis[maxn]={false};//标记是否被访问 
//DFS函数访问单个连通块,nowVisit为当前访问的编号
//head为头目,numMember为成员编号,totalValue为连通块的总边权
void DFS(int nowVisit,int &head,int &numMember,int &totalValue)
{
	numMember++;//成员人数加1
	vis[nowVisit]=true;//标记nowVist已经被访问
	if(weight[nowVisit]>weight[head])
	{
		head=nowVisit;//当前访问结点的点权大于头目的点权,则更新头目 
	} 
	for(int i=0;i<numPerson;i++)
	{
		//枚举所有人
		if(G[nowVisit][i]>0)
		{
			//如果从nowVisit能到达i
			totalValue+=G[nowVisit][i];//连通块的总边权增加该边权
			G[nowVisit][i]=G[i][nowVisit]=0;//删除这条边,防止回头
			if(vis[i]==false)
			{
				DFS(i,head,numMember,totalValue);
			} 
		} 
	} 
} 
//DFSTrave函数遍历整个图,获取每个连通块的信息
void DFSTrave()
{
	for(int i=0;i<numPerson;i++)
	{
		//枚举所有人
		if(vis[i]==false)
		{
			//如果i未被访问
			int head=i,numMember=0,totalValue=0; //头目,成员数,总边权
			DFS(i,head,numMember,totalValue);//遍历i所在的连通块
			if(numMember>2 && totalValue>k)
			{
				//成员人数大于2且总边权大于k
				//head人数为numMember
				Gang[intToString[head]]=numMember; 
			} 
		} 
	}
} 
//change函数返回姓名str对应的编号
int change(string str)
{
	if(stringToInt.find(str)!=stringToInt.end())
	{
		//如果str已经出现过
		return stringToInt[str];//返回编号 
	}else{
		stringToInt[str]=numPerson;//str的编号为numPerson
		intToString[numPerson]=str;//numPerson对应str
		return numPerson++;//总人数加1 
	}
} 
int main()
{
	int w;
	string str1,str2;
	cin>>n>>k;
	for(int i=0;i<n;i++)
	{
		cin>>str1>>str2>>w;//输入边的两个端点和点权
		int id1=change(str1);//将str1转换为编号id1
		int id2=change(str2);//将str2转换为编号id2
		weight[id1]+=w;//id1的点权增加w 
		weight[id2]+=w;//id2的点权增加w 
		G[id1][id2]+=w;//边id1->id2的边权增加w
	    G[id2][id1]+=w;//边id2->id1的边权增加w
	} 
	DFSTrave();//遍历整个图的所有连通块,获取Gang的信息
	cout<<Gang.size()<<endl;//Gang的个数
	map<string,int>::iterator it;
	for(it=Gang.begin();it!=Gang.end();it++){
		//遍历所有Gang
		cout<<it->first<<" "<<it->second<<endl;//输出信息 
	} 
	return 0; 
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值