1003 Emergency

1003 Emergency (25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
题意:给出N个城市,M条无向边。每个城市中都有一定数目的救援小组,所有边的边权已知。现在给出起点和终点,求所有起点到终点的最短路径条数以及最短路径上的救援小组数目之和。
思路:在求解最短距离的同时需要求解另外两个信息:最短路径条数和最短路径上的最大点权之和。
核心代码

if(vis[v]==false && G[u][v]!=INF)
			{
				if(d[u]+G[u][v]<d[v])
				{
					//以u为中介点时能令d[v]变小 
					d[v]=d[u]+G[u][v];//覆盖d[v] 
					w[v]=w[u]+weight[v];//覆盖w[v] 
					num[v]=num[u];//覆盖num[v] 
				}else if(d[u]+G[u][v]==d[v])
				{
					//找到一条相同长度的路径 
					if(w[u]+weight[v]>w[v])
					{
					//以u为中介点时点权之和更大 
						w[v]=w[u]+weight[v];//w[v]继承自w[u] 
					}
					num[v]+=num[u];//注意最短路径条数与点权无关,写在外面 
				}
			}

该题目代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXV=510;//最大顶点数
const int INF=1000000;//无穷大

//n为顶点数,m为边数,st为起点,ed为终点
//G为邻接矩阵,weight为点权
//d[]记录最短距离,w[]记录最大点权之和,
//num[]记录最短路径条数
int n,m,st,ed,G[MAXV][MAXV],weight[MAXV];
int d[MAXV],w[MAXV],num[MAXV];
bool vis[MAXV]={false};
void Dijkstra(int s)
{
	fill(d,d+MAXV,INF);
	memset(w,0,sizeof(w));
	d[s]=0;
	w[s]=weight[s];
	num[s]=1;
	for(int i=0;i<n;i++)
	{
		int u=-1,MIN=INF;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false && d[j]<MIN)
			{
				u=j;
				MIN=d[j];
			}
		}
		if(u==-1)return;
		vis[u]=true;
		for(int v=0;v<n;v++)
		{
			if(vis[v]==false && G[u][v]!=INF)
			{
				if(d[u]+G[u][v]<d[v])
				{
					//以u为中介点时能令d[v]变小 
					d[v]=d[u]+G[u][v];
					w[v]=w[u]+weight[v];
					num[v]=num[u]; 
				}else if(d[u]+G[u][v]==d[v])
				{
					if(w[u]+weight[v]>w[v])
					{
						w[v]=w[u]+weight[v];
					}
					num[v]+=num[u];
				}
			}
		} 
	}
} 
int main()
{
	scanf("%d%d%d%d",&n,&m,&st,&ed);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&weight[i]);//读入点权 
	}
	int u,v;
	fill(G[0],G[0]+MAXV*MAXV,INF);
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&u,&v);//边
		scanf("%d",&G[u][v]);//边权
		G[v][u]=G[u][v]; 
	}
	Dijkstra(st);
	printf("%d %d\n",num[ed],w[ed]);//最短距离条数,最短路径中最大点权
	return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值