POJ 3278 Catch That Cow(广搜BFS)

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 119279 Accepted: 37221

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

源代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
int N,K;
const int MAXN=100000;
int visited[MAXN+10];
using namespace std;
struct Step{
    int x;
    int steps;
    Step(int xx,int s):x(xx),steps(s){}
};
queue<Step>q;
int main(){
    cin>>N>>K;
    memset(visited,0,sizeof(visited));
    q.push(Step(N,0));
    visited[N]=1;
    while(!q.empty()){
        Step s =q.front();
        if(s.x==K){
            cout<<s.steps<<endl;
            return 0;
        }
        else{
            if(s.x-1>=0&&!visited[s.x-1]){
                q.push(Step(s.x-1,s.steps+1));
                visited[s.x-1]=1;
            }
            if(s.x+1<=MAXN&&!visited[s.x+1]){
                q.push(Step(s.x+1,s.steps+1));
                visited[s.x+1]=1;
            }
            if(s.x*2<=MAXN&&!visited[s.x*2]){
                q.push(Step(s.x*2,s.steps+1));
                visited[s.x*2]=1;
            }
            q.pop();
        }
    }
    return 0;
}

思路:解决BFS最好的思路就是把广搜的思想和队列结合从而快速解决问题

          这里我们用一个队列q储存起点,并且构造一个新的函数Step用来记录每一次寻找的起点以及走过的路径长度

         如果说某个节点没有访问过就压入队尾,最后统计到目标节点的最小距离,弹出队列。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值