POJ-3278 Catch That Cow(bfs+剪枝)

22 篇文章 0 订阅
16 篇文章 0 订阅

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意就是给你两个数 n , k n, k n,k,对于 n n n,有两种操作
  • 加一
  • 减一
  • 乘二
问你最快达到 k k k,需要多少步。
做法:简单广搜即可,但需注意一定要剪枝,要不然内存会超
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <sstream>
#include <set>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
const int N = 1e5 + 10;
const int mod = 1e9 + 7;
#define ll long long

int n, k;
int vis[N];			//用来标记数字同时记录步数,达到的数字不再重复放入队列

void bfs(int x)
{
	memset(vis, 0, sizeof(vis));
	queue<int> s;
	s.push(x);
	while(!s.empty()){
		int cnt = s.front();
		s.pop();
		if(cnt == k){
			printf("%d\n", vis[k]);
			break;
		}
		if(cnt > 0 && !vis[cnt-1]){
			int z = cnt - 1;
			s.push(z);
			vis[z] = vis[cnt]+1;
		}
		if(cnt < k && !vis[cnt+1]){
			int z = cnt + 1;
			s.push(z);
			vis[z] = vis[cnt]+1;
		}
		if(2*cnt <= N && !vis[2*cnt]){
			int z = cnt * 2;
			s.push(z);
			vis[z] = vis[cnt]+1;
		}
	}
}

int main()
{
	cin >> n >> k;
	bfs(n);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值