Dropping tests(最大化平均值) POJ2976

Dropping tests

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22108 Accepted: 7418

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

Stanford Local 2005

Code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn = 1005;
int n,k,a[maxn],b[maxn];
double y[maxn];

int check(double mid)
{
    for(int i=0;i<n;i++)
    {
        y[i]=a[i]-b[i]*mid;
        //cout<<"**"<<y[i]<<endl;
    }
    sort(y,y+n);
    double sum=0;
    for(int i=n-1;i>=k;i--)
    {
        sum+=y[i];
        //cout<<"*/"<<sum<<endl;
    }
        return sum>=0;
}
void solve()
{
    double l=0,r=1;
    //cout<<l<<" "<<r<<endl;
    while(fabs(l-r)>=1e-8)
    {

        double mid = (l+r)*1.0/2;
        //cout<<mid<<endl;
        if(check(mid))
            l=mid;
        else
            r=mid;
    }
    printf("%.0f\n",l*100);
}
int main()
{

    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    while(cin>>n>>k)
    {

        if(n==0&&k==0)
        {
            break;
        }
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        for(int i=0;i<n;i++)
        {
            cin>>b[i];
        }
        solve();
    }

    return 0;
}

01分数规划,这道题我一开始当成纯贪心做了,后来发现是这样的意思:

设有n个成绩,分别输入ai和bi,然后累加,求ai总和/bi总和。

这是常规的算法,现在要求的是从n个成绩当中取出k对成绩,要求取k对成绩之后,得到的平均成绩最大并进行输出。

然后这题就是二分的思想了,我用一个l=0和r=1代表左右边界,然后依次取他们的中值,

然后取a[i]-b[i]*mid,这里用一个yi进行存储,然后进行排序,从n-1到k输出(k之前的说明这个东西对总成绩的贡献小,然后就不累加了)

最后输出mid就可以了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值