Calculator Conundrum UVA - 11549(set判重)

题目链接

https://vjudge.net/problem/UVA-11549

题目

Alice got a hold of an old calculator that can display n digits. She was bored enough to come up with
the following time waster.
She enters a number k then repeatedly squares it until the result overflows. When the result
overflows, only the n most significant digits are displayed on the screen and an error flag appears. Alice
can clear the error and continue squaring the displayed number. She got bored by this soon enough,
but wondered:
“Given n and k, what is the largest number I can get by wasting time in this manner?”

Input

The first line of the input contains an integer t (1 ≤ t ≤ 200), the number of test cases. Each test case
contains two integers n (1 ≤ n ≤ 9) and k (0 ≤ k < 10n) where n is the number of digits this calculator
can display k is the starting number.

Output

For each test case, print the maximum number that Alice can get by repeatedly squaring the starting
number as described.

Sample Input

2
1 6
2 99

Sample Output

9
99

题意

给定一个老式计算器,计算器只能显示n位。输入一个整数k,反复平方,如果溢出计算器显示结果的最高n位。继续平方。问在这个反复平反的过程中,计算器显示的最大值为多少。

分析

观察得,反复平方的过程是循环的,所以,只需在一次循环的过程中选出最大值即可。
而判断循环则可以通过判断该值在之前是否出现过来实现,这里采用set判重 (map判重也可以)

代码

#include <cstdio>
#include <set>
#include <algorithm>

using namespace std;
typedef long long ll;

ll t;

ll next(ll n,ll k)
{
    ll k2=k*k;
    ll a[101],d=0;
    while(k2)
    {
        a[d++]=k2%10;
        k2/=10;
    }
    ll sum=min(n,d);
    ll ans=0;
    while(sum--)
    {
        ans=ans*10+a[--d];
    }
    return ans;
}

int main()
{
    ll n,k;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&k);
        set<int> s;
        ll ans=k;
        while(!s.count(k))
        {
            s.insert(k);
            ans=max(ans,k);
            k=next(n,k);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

优化

set判重需要比价大的空间开销,为了节约空间,我们可以采用Floyed判圈算法。
Floyed判圈算法:
两个人A和B在一个圆形跑道上跑步,一开始在同一起跑线,A的速度是B的两倍。当A第一次追上B时,B刚好跑完一圈。

优化后的代码

#include <cstdio>
#include <set>
#include <algorithm>

using namespace std;
typedef long long ll;

ll t;

ll next(ll n,ll k)
{
    ll k2=k*k;
    ll a[101],d=0;
    while(k2)
    {
        a[d++]=k2%10;
        k2/=10;
    }
    ll sum=min(n,d);
    ll ans=0;
    while(sum--)
    {
        ans=ans*10+a[--d];
    }
    return ans;
}

int main()
{
    ll n,k;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&k);

        ll ans=k,k1=k,k2=k;
        do
        {
            k1=next(n,k1);
            k2=next(n,k2);
            ans=max(ans,k2);
            k2=next(n,k2);
            ans=max(ans,k2);
        }while(k1!=k2);
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值