ZOJ3261 Connections in Galaxy War (逆向执行操作序列使”删边“成”加边“)

77 篇文章 0 订阅
17 篇文章 0 订阅

题目链接

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3261

题目

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn’t find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, … , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It’s guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

“destroy a b” - the connection between star a and star b was destroyed by the monsters. It’s guaranteed that the connection between star a and star b was available before the monsters’ attack.

“query a” - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output “-1”; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1
Sample Output

1
-1
-1
-1

题意

给定一个无向图,每一个点都有一个权值。对于操作:
query a:表示查询点a所能到达的权值最大的点,如果没有比a权值大的a所能到达的点,则输出-1.否则,输出该点的编号。
destroy a b:表示破坏边(a,b).

分析

注意到题目保证在边(a,b)被破坏之前一定存在。也就是删边操作只对后续操作有影响,边存在与否只对之前的操作有影响。
对不会被删的边建立并查集。然后逆向执行操作序列,对于删边操作,添加一个边以保证逆向执行不改变图的正确性。对于查询操作,判断根的权值与a的权值是否相等即可。

AC代码

#include <bits/stdc++.h>
#define HASH 100000
using namespace std;
const int maxn=1e4+100;
const int maxm=2e4+100;
const int maxe=5e4+100;
int par[maxn],w[maxn];
map<int,bool> mp;
int N,M;
struct opration
{
    char s[10];
    int x,y;
}a[maxe];
struct edge
{
    int u,v;
}e[maxm];
//bool vis[maxn][maxn];用二维数组会段错误
void init()
{
    //memset(vis,false,sizeof(vis));
    mp.clear();
    for(int i=0;i<=N;i++) par[i]=i;
}
int find(int x)
{
    return par[x]==x?x:par[x]=find(par[x]);
}
void unit(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx==fy) return ;

    if(w[fx]==w[fy])
    {
        if(fx<fy) swap(fx,fy);
        par[fx]=fy;
        return ;
    }
    if(w[fx]>w[fy]) swap(fx,fy);
    par[fx]=fy;
    return ;
}
int ans[maxn];
int main()
{
    bool flag=false;
    while(~scanf("%d",&N))
    {
        for(int i=0;i<N;i++)//一开始下标从1开始了,WA...
            scanf("%d",&w[i]);
        init();
        scanf("%d",&M);
        for(int i=1;i<=M;i++)
        {
            scanf("%d%d",&e[i].u,&e[i].v);
            if(e[i].u>e[i].v) swap(e[i].u,e[i].v);
        }

        int q;
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%s",a[i].s);
            if(a[i].s[0]=='q')
                scanf("%d",&a[i].x);
            else
            {
                int u,v;
                scanf("%d%d",&a[i].x,&a[i].y);
                if(a[i].x>a[i].y) swap(a[i].x,a[i].y);
                u=a[i].x,v=a[i].y;
                mp[u*HASH+v]=true;
            }

        }
        //建立从未被破坏的边所组成的并查集
        for(int i=1;i<=M;i++)
        {
            int u=e[i].u,v=e[i].v;
            if(mp[u*HASH+v]==true) continue;//会被破坏
            unit(u,v);
        }
        int tot=0;
        for(int i=q;i>=1;i--)
        {
            if(a[i].s[0]=='d')
            {
                int x=a[i].x,y=a[i].y;
                unit(x,y);
            }
            else
            {
                int x=a[i].x;
                int fx=find(x);
                ans[++tot]=(find(x)==x||w[find(x)]==w[x])?-1:find(x);
            }
        }
        if(flag) puts("");
        else flag=true;
        for(int i=tot;i>=1;i--)
            printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值