zoj Connections in Galaxy War(逆向并查集)

115 篇文章 0 订阅
21 篇文章 0 订阅
 Connections in Galaxy War

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star Adirectly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes starA couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <=pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab<= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star bwas available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

ps:传统的做法是先把输入的点加入并查集建立关系,然后开始判断询问,遇到destroy就将那两个点之间的关系断开,但是很明显,这样很难做到将其关系断开

因此,我们可以逆向想一下了,我们可以先把所有的输入数据都存起来,然后先把未destroy的点与点之间建立关系,这样我们就可以从最后一个询问开始判断并记录下结果,当遇到destroy时再把这两个点建立关系,这样destroy前面的询问就可以正确地判断了

代码:
#include<stdio.h>
#include<map>
#include<stdlib.h>
#include<string.h>
using namespace std;

#define maxn 10000+10
#define maxv 20000+10
#define maxx 50000+10
const int Hash=10000;
int pre[maxn],rank[maxn],ans[maxx];
struct build
{
    int x,y;
} p[maxv];//记录建立关系的点
struct node
{
    char s[10];
    int x,y;
} q[maxx];//记录询问
int n;
map<int,bool>vis;//标记destroy的点

void init()
{
    for(int i=0; i<n; i++)
        pre[i]=i;
}

int Find(int x)
{
    int temp=pre[x];
    if(x==pre[x])
        return x;
    pre[x]=Find(temp);
    return pre[x];
}

void join(int x,int y)
{
    int fx=Find(x),fy=Find(y);
    if(fx!=fy)
    {
        if(rank[fx]>rank[fy])
            pre[fy]=fx;
        else if(rank[fx]<rank[fy])
            pre[fx]=fy;
        else
        {
            if(fx<fy)
                pre[fy]=fx;
            else
                pre[fx]=fy;
        }
    }
}

int main()
{
    int flag=0;
    while(~scanf("%d",&n))
    {
        if(flag)
            puts("");
        else
            flag=1;
        int i,m,Q;
        for(i=0; i<n; i++)
            scanf("%d",&rank[i]);
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);//记录加入的边
            if(p[i].x>p[i].y)//变成前小后大的形式,保持p[i].x*Hash+p[i].y]的正确性
                swap(p[i].x,p[i].y);
        }
        scanf("%d",&Q);
        vis.clear();
        for(i=0; i<Q; i++)//记录询问
        {
            scanf("%s",q[i].s);
            if(!strcmp(q[i].s,"query"))
                scanf("%d",&q[i].x);
            else
            {
                scanf("%d%d",&q[i].x,&q[i].y);
                if(q[i].x>q[i].y)
                    swap(q[i].x,q[i].y);//同理
                vis[q[i].x*Hash+q[i].y]=true;
            }
        }
        init();
        for(i=0; i<m; i++)//将未destroy的点加入集合
            if(!vis[p[i].x*Hash+p[i].y])
                join(p[i].x,p[i].y);
        int ps=0;
        for(i=Q-1; i>=0; i--)//从后面开始判断询问
        {
            if(!strcmp(q[i].s,"query"))
            {
                int fa=Find(q[i].x);
                if(rank[fa]>rank[q[i].x])
                    ans[ps++]=fa;
                else
                    ans[ps++]=-1;
            }
            else
                join(q[i].x,q[i].y);
        }
        for(i=ps-1; i>=0; i--)//输出结果
            printf("%d\n",ans[i]);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值