传送门 Time Limit: 2000MS Memory Limit: 65536K
Description
Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5
题目大意
农民约翰的某N(1 < N < 80000)头奶牛正在过乱头发节!由于每头牛都意识到自己凌乱不堪 的发型,约翰希望统计出能够看到其他牛的头发的牛的数量.
每一头牛i有一个高度所有N头牛面向东方排成一排,牛N在最前面,而 牛1在最后面.第i头牛可以看到她前面的那些牛的头,只要那些牛的高度严格小于她的高度,而且 中间没有比hi高或相等的奶牛阻隔.
让N表示第i头牛可以看到发型的牛的数量;请输出Ci的总和
思路及代码
对于每一个牛来说,能看到的数目为向右数身高比它小的个数,累加就是答案。
所以可以倒着维护一个单调递增的栈,记录i之前的弹栈数目,累加。
(正着也可以,那么就是维护对于每一头牛来说,它被多少头牛看到)
#include<cstdio>
#define MAXN 80005
#define llu unsigned long long
using namespace std;
llu n,ans=0;
long long s_size=-1;
llu s[MAXN];
int main()
{
scanf("%llu",&n);
for(llu i=1;i<=n;i++)
{
llu x;
scanf("%llu",&x);
while(s_size>=0&&x>=s[s_size])s_size--;
s[++s_size]=x;
ans+=s_size;
}
printf("%llu\n",ans);
return 0;
}