Catch That Cow

题目链接
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Example Input
5 17
Example Output
4
注意点:
1.poj上是一组输入,所以下面的代码对,hdu是多组输入,所以每次进行之前
都要清空队列,我们下面的代码,也是以hdu上为准.
2.遇到加法的时候一定要注意是不是越界了,采用剪枝.

#include<bits/stdc++.h>
using namespace std;
int bfs(int s,int e){
	    bool vis[100005];
	    memset(vis,0,sizeof vis);
		    queue <pair<int,int>> Q;
		    while(!Q.empty()) Q.pop();
		    vis[s] = true;
		    Q.push({s,0});
		    while(!Q.empty()){
			    	    pair<int,int> fnt = Q.front();
			    	    Q.pop();
			    	    for(int i = 1;i <= 3;i++){
				    	    	    int tx;
				    	    	    if(i == 1) tx = fnt.first - 1;
				    	    	    else if(i == 2) tx = fnt.first + 1;
				    	    	    else tx = fnt.first * 2;
				    	    	    if(tx < 0 || tx > 100000) continue;
				    	    	    if(!vis[tx]){
					    	    	    	    vis[tx] = true;
					    	    	    	    Q.push({tx,fnt.second + 1});
				    	    	    }
				    	    	    if(tx == e) return fnt.second + 1;
			    	    }
	}
	return 0;
}
int main(){
	    int n,k;
	    while(~scanf("%d%d",&n,&k)){
		        if(n >= k) printf("%d\n",n - k);
		        else printf("%d\n",bfs(n,k));
	    }		
	    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值