Parity check[山东省第八届ACM大学生程序设计竞赛]

题目链接
Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:
f(n)=这里写图片描述
She is required to calculate f(n) mod 2 for each given n. Can you help her?
Input

Multiple test cases. Each test case is an integer n(0≤n≤) in a single line.
Output

For each test case, output the answer of f(n)mod2.
Sample Input

2
Sample Output

1

解题思路:
1.打表找规律,发现以0 1 1 这三个数进行循环
2.Java大数模板,暴力

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		//第一个注意点,多组测试数据,Java中的表示方法in.hasNextBigInteger()
		while(in.hasNextBigInteger()){
			BigInteger a = in.nextBigInteger();
			//第二个注意点,Java大数中的'=='使用equal()函!数!
			if(a.mod(BigInteger.valueOf(3)).equals(BigInteger.valueOf(0)))
				System.out.println(0);
			//第二个注意点,Java大数中的'=='使用equal()函!数!
			else if(a.mod(BigInteger.valueOf(3)).equals(BigInteger.valueOf(1)))
				System.out.println(1);
			//第二个注意点,Java大数中的'=='使用equal()函!数!
			else
				System.out.println(1);
		}		
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值