ACM 第八届山东省赛 I Parity check SDUT 3901



题目再现链接: 点击打开链接

Parity check

Time Limit: 2000MS  Memory Limit: 524288KB
Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=

She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input

Multiple test cases. Each test case is an integer n(0≤n) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Example Input
2
Example Output
1
Hint
Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

 找规律, 会发现%2   每三位 都是0 1 1   因此 看是 %3 余几即可 但又因为是10^1000  因此是个大数  ,大数处理 就行


#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdio.h>
#include <string>

using namespace std;

int main()
{
    string s;
    int sum=0;
    int i;
    while(cin>>s)
    {
        int len=s.length();
        sum=0;
        for(i=0;i<len;i++)
        {
            sum+=(s[i]-'0')%3;
        }
        sum%=3;
        switch(sum)
        {
            case 1:printf("1\n");break;
            case 0:printf("0\n");break;
            case 2:printf("1\n");break;
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值