Fibonacci (矩阵快速幂)

题目链接
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is
                                    在这里插入图片描述
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

                                             在这里插入图片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

                                             在这里插入图片描述

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
struct matrix{
	long long int mat[2][2];
}A,B;
matrix mul(matrix a,matrix b){
	matrix tmp;
	memset(tmp.mat,0,sizeof(tmp.mat));//注意初始化!!
	for(int i = 0;i < 2;i++)
		for(int j = 0;j < 2;j++)
			for(int k = 0;k < 2;k++)//注意i,j,k的摆放位置
				tmp.mat[i][j] += a.mat[i][k] * b.mat[k][j] % 10000;
	return tmp;
}
matrix pow_mat(matrix a,int n){
	matrix ans;
	for(int i = 0;i < 2;i++)
		for(int j = 0;j < 2;j++)
			i == j ? ans.mat[i][j] = 1 : ans.mat[i][j] = 0;//初始化为单位矩阵
	while(n){
		if(n & 1)
			ans = mul(ans,a);
		a = mul(a,a);
		n >>= 1;
	}
	return ans;
}
int main(){
	long long int n;
	while(~scanf("%lld",&n)){
		if(n == -1)
			break;
		else if(n == 0 || n == 1){
			printf("%lld\n",n);
			continue;
		}
		else{
			A.mat[0][0] = 1,A.mat[0][1] = 0;
			B.mat[0][0] = 1,B.mat[0][1] = 1;
			B.mat[1][0] = 1,B.mat[1][1] = 0;
			B = pow_mat(B,n - 1);
			printf("%lld\n",mul(A,B));
		}
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值