Coloring Game (找规律+快速幂)

题目链接
David has a white board with 2×N grids.He decides to paint some grids black with his brush.He always starts at the top left corner and ends at the bottom right corner, where grids should be black ultimately.

Each time he can move his brush up(↑), down(↓), left(←), right(→), left up(↖), left down(↙), right up(↗), right down (↘) to the next grid.

For a grid visited before,the color is still black. Otherwise it changes from white to black.

David wants you to compute the number of different color schemes for a given board. Two color schemes are considered different if and only if the color of at least one corresponding position is different.

Input
One line including an integer n(0<n≤109)

Output
One line including an integer, which represent the answer mod1000000007

样例输入1
2

样例输出1
4

样例解释1

在这里插入图片描述

样例输入2
3

样例输出2
12

样例解释2
在这里插入图片描述
题解:(如下图所示)

在这里插入图片描述

#include<bits/stdc++.h>
using namespace std;
const int N = 1e9 + 7;
int quick_pow(int a,int b){
	int res = 1;
	while(b){
		if(b & 1) res = res * 1ll * a % N;
		b >>= 1;
		a = a * 1ll * a % N;
	}
	return res;
}
int main(){
	ios :: sync_with_stdio(false);
	cin.tie(0);
	int n;
	cin >> n;
	if(n == 1) cout << 1 << endl;
	else cout << 4 * 1ll * quick_pow(3,n - 2) % N << endl;
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值