Coloring Game

David has a white board with 2 \times N2×N grids.He decides to paint some grids black with his brush.He always starts at the top left corner and ends at the bottom right corner, where grids should be black ultimately.

Each time he can move his brush up(), down(), left(), right(), left up(), left down(), right up(), right down () to the next grid.

For a grid visited before,the color is still black. Otherwise it changes from white to black.

David wants you to compute the number of different color schemes for a given board. Two color schemes are considered different if and only if the color of at least one corresponding position is different.

Input

One line including an integer n(0<n \le 10^9)n(0<n≤109)

Output

One line including an integer, which represent the answer \bmod 1000000007mod1000000007

样例输入1复制

2

样例输出1复制

4

样例输入2复制

3

样例输出2复制

12

样例解释2

规律题:N不管是几,左下角和右上脚都不会对结果路径影响(不走也能走的通),去掉两列分析中间N-2列可以得到规律。然后通过快速幂求解。 

#include<iostream>
#include<cstdio>
#include<cmath>
typedef long long ll;
const ll mod = 1000000007;

using namespace std;

ll pow_mod(ll a,ll b){
    ll result = 1;
    ll base = a%mod;
    while(b){
        if(b&1)
            result = (result*base)%mod;
        base = (base*base)%mod;
        b/=2;
    }
    return result;
}
int main()
{
    ll m;
    cin>>m;
    if(m == 1){
        cout<<1<<endl;
    }
    else
        cout<<(4*pow_mod(3,m-2))%mod;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值