Description
1 4 3 2 9 7 18 22
your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1
Sample Output
3
2
0
这道题就是把输入的两个数字翻转相加再翻转,题目不难,但提交了好多次,就是那个数据类型必须long long int(绝望啊)
#include<bits/stdc++.h>
using namespace std;
int oppsite(int k)
{
long long int a,b=0,c,d;
while(k!=0)
{
a=k%10;
k/=10;
b+=a;
b*=10;
}
return b/10;
}
int main()
{
long long int a,i,n,x,y,p,l,op,ol;
cin>>n;
for(i=0;i<n;i++)
{
cin>>x>>y;
p=oppsite(x);
l=oppsite(y);
op=p+l;
ol=oppsite(op);
cout<<ol<<endl;
}
}