Problem R-18 Prime Number

Description

Prime Number Definition 
An integer greater than one is called a prime number if its only positive divisors (factors) are one and itself. For instance, 2, 11, 67, 89 are prime numbers but 8, 20, 27 are not.

Semi-Prime Number Definition 
An integer greater than one is called a semi-prime number if it can be decompounded to TWO prime numbers. For example, 6 is a semi-prime number but 12 is not.

Your task is just to determinate whether a given number is a semi-prime number.

Input

There are several test cases in the input. Each case contains a single integer N (2 <= N <= 1,000,000)

Output

One line with a single integer for each case. If the number is a semi-prime number, then output "Yes", otherwise "No".

Sample Input

3
4
6
12

Sample Output

No 
Yes 
Yes 

No 

题目介绍
半素数
题目定义了一种叫半素数的数:只要一个数能被分解成两个素数,那么这个数就是半素数。
解题思路:
先判断n是不是素数,如果是素数,则计算n因子的个数,如果多于2个则不是半素数,若少于两个,则再判断因子是否为素数
代码:
#include<bits/stdc++.h>
using namespace std;
int s(int a)
{
    int t=sqrt(a),i;
    for( i=2;i<=t;i++)
      if(a%i==0)
        break;
    if(i>t)
        return 1;
    else
        return 0;
}
int main()
{
   int n;
   while(cin>>n)
   {
       int t=sqrt(n),i,a,m=0;
       if(s(n))
        cout<<"No"<<endl;
       else
        {for(i=2;i<=t;i++)
            if(n%i==0)
            {
               m++;
               a=i;
            }
            if(m>1)
                cout<<"No"<<endl;
            else
                if(s(a)&&s(n/a))
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }


   }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值