2018/7/16 Friends 训练日记3

Problem Description

There are people and pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these people wants to have the same number of online and offline friends (i.e. If one person has onine friends, he or she must have offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 

 

 

Input

The first line of the input is a single integer , indicating the number of testcases. 

For each testcase, the first line contains two integers and , indicating the number of people and the number of pairs of friends, respectively. Each of the next lines contains two numbers and , which mean and are friends. It is guaranteed that and every friend relationship will appear at most once. 

Output

For each testcase, print one number indicating the answer.

Sample Input

2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1

Sample Output

0 2

题意:给出n个人,m个朋友关系,每个关系可以为在线或离线,问如果要让每个人的在线朋友数和离线朋友数相同,那么关系组成有多少种情况。(n<=8,m<=n*(n-1)/2)

思路:

如果一个人的朋友数(转化为点的度)为奇数,肯定不能让在线朋友和离线朋友数相同。这种情况剔除之后,把每个人的朋友数分成相同的两拨,然后就是走关系图的每一条边,走一遍是一种情况。

DFS+剪枝操作

代码:

#include<bits/stdc++.h>
using namespace std;
#define maxn 30
int degree[10],x[maxn],y[maxn];
int onl[maxn],off[maxn];
int res=0,n,m;
void dfs(int num){ 
    if(num==m+1){
        bool ff=false;
        for(int i=1;i<=n;i++){
            if(onl[i]!=off[i]){
                ff=true;
                break;
            }
        }
        if(!ff) 
                        res++;
        return ;
    }
    int u=x[num],v=y[num];
    if(onl[u]<degree[u]/2&&onl[v]<degree[v]/2){
        onl[u]++;
        onl[v]++;
        dfs(num+1);
        onl[u]--;
        onl[v]--;
    }
    if(off[u]<degree[u]/2&&off[v]<degree[v]/2){ 
        off[u]++;
        off[v]++;
        dfs(num+1);
        off[u]--;
        off[v]--;
    }
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        memset(degree,0,sizeof(degree));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
                {
            scanf("%d%d",&x[i],&y[i]);
            degree[x[i]]++; 
            degree[y[i]]++;
        }
        res=0;
        dfs(1);
        printf("%d\n",res);
    }
    return 0;
}
 

感受:感觉多校联合的题有点难,这个题算是个例外了感觉,其他的几个感觉不好想也不好写的,但人家都说是签到题啊

瞎搞就出来了什么的,有点丧。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值