05-树9 Huffman Codes

18 篇文章 0 订阅
1 篇文章 0 订阅

05-树9 Huffman Codes(30 分)
In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] … c[N] f[N]
where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]
where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 ‘0’s and ‘1’s.

Output Specification:

For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11
Sample Output:

Yes
Yes
No
No

#include <iostream>
#include <string>
using namespace std;
const int minData=-1;
struct HuffmanTree
{
    int f;
    HuffmanTree *left=NULL;
    HuffmanTree *right=NULL;
};
struct minHeap
{
    HuffmanTree *data;
    int Size=0;
};
minHeap* Create(int maxSize)
{
    minHeap* H=new minHeap;
    H->data=new HuffmanTree[maxSize+1];
    H->data[0].f=minData;
    return H;
}
void Insert(HuffmanTree* x,minHeap* H)
{
    int i=++H->Size;
    for(;H->data[i/2].f>x->f;i/=2){
        H->data[i]=H->data[i/2];
    }
    H->data[i]=*x;
}
HuffmanTree* Delete(minHeap *H)
{
    int parent,child;
    HuffmanTree temp=H->data[H->Size--];
    HuffmanTree *minItem=new HuffmanTree;
    *minItem=H->data[1];
    for(parent=1;parent*2<=H->Size;parent=child){
        child=parent*2;
        if(child+1<=H->Size
           && H->data[child].f>H->data[child+1].f){
            child++;
        }
        if(temp.f<=H->data[child].f) break;
        else H->data[parent]=H->data[child];
    }
    H->data[parent]=temp;
    return minItem;
}
HuffmanTree* BuildHuffmanTree(int m,minHeap* H)
{
    HuffmanTree* T;
    for(int i=0;i<m-1;i++){
        T=new HuffmanTree;
        T->left=Delete(H);
        T->right=Delete(H);
        T->f=T->left->f+T->right->f;
        Insert(T,H);
    }
    return Delete(H);
}
int wpl(HuffmanTree* T,int h)
{
    if(!T->left && !T->right) return h*(T->f);
    else return wpl(T->left,h+1) + wpl(T->right,h+1);
}
void check(int n,int freq[],HuffmanTree* T)
{
    int i,j,is=1,sum=0;
    char c;
    string s[n];
    for(i=0;i<n;i++){
        cin>>c>>s[i];
        if(s[i].size()>n-1) break;
        for(j=0;j<i;j++){
            if(s[i]==s[j]) break;
            if(s[i].size()+1==s[j].size()){
                if(s[i]==s[j].substr(0,s[i].size())) break;
            }
        }
        if(j<i) break;
        sum+=s[i].size()*freq[i];
    }
    if(i<n || sum!=wpl(T,0)) is=0;
    for(;i<n-1;i++) cin>>c>>s[i];
    if(is) cout<<"Yes"<<endl;
    else cout<<"No"<<endl;
}
int main()
{
    int m,n;
    char c;
    cin>>m;
    int freq[m];
    minHeap* H=Create(m);
    HuffmanTree* T;
    for(int i=0;i<m;i++){
        cin>>c>>freq[i];
        HuffmanTree* node=new HuffmanTree;
        node->f=freq[i];
        Insert(node,H);
    }
    T=BuildHuffmanTree(m,H);
    cin>>n;
    for(int i=0;i<n;i++){
        check(m,freq,T);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值