Sumsets
Time Limit: 2000MS | Memory Limit: 200000K | |
Total Submissions: 21492 | Accepted: 8355 |
Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4
Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4
Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
Input
A single line with a single integer, N.
Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7
Sample Output
6
Source
递推式:
若n为奇数,则f(n) = f(n-1);
若n为偶数,则n的所有等式中,有一部分全部由偶数构成,另一部分则含有1,且1的数目为偶数个,对于前者,其数量等于f(n/2),对于后者,其数量等于f(n-1),则f(n) = f(n-1) + f(n/2)。
#include<cstdio>
using namespace std;
const int maxn = 1000005,nn = 1000000000;
int n,dp[maxn];
void solve(){
scanf("%d",&n);
dp[1] = 1;
for(int i = 2;i <= n;i++){
if(i % 2) dp[i] = dp[i-1] % nn;
else dp[i] = dp[i-1] + dp[i/2] % nn;
}
printf("%d\n",dp[n]);
}
int main()
{
solve();
return 0;
}