HDU-2196-Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31489    Accepted Submission(s): 4111


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4

题意:求各个点能够到达的最远距离。

  节点能到达的最远距离考虑往上父节点方向,往下儿子节点方向,然后搜两次,第一次求从父节点方向的最远距离,第二次儿子节点方向的最远距离。这题也算是入门题吧,不过当时懵懵懂懂刚开始学,用的word中的写法。

代码:

  

#include<iostream>
#include<string.h>
#include<math.h>
#include<stdio.h>
#include<vector>
using namespace std;
vector<int>son[10005],v[10005];
int bj[10005],g[10005],ll[10005],h[10005];
int dfs(int p)
{
int flag;
if(bj[p])
    return bj[p];
int l=son[p].size();
if(l==0)
    return 0;
for(int i=0;i<l;i++)
    {
    int j=son[p][i];
    if(dfs(j)+v[p][i]>bj[p])
        {
        g[p]=bj[p];
        bj[p]=bj[j]+v[p][i];
        flag=j;
        }
    else  if(bj[j]+v[p][i]>g[p])
            g[p]=bj[j]+v[p][i];
    }
ll[p]=flag;
return bj[p];
}
void dfs1(int p)
{
int l=son[p].size();
for(int i=0;i<l;i++)
    {
    int j=son[p][i];
    if(j==ll[p])
        h[j]=max(h[p],g[p])+v[p][i];
    else
        h[j]=max(h[p],bj[p])+v[p][i];
    dfs1(j);
    }
}
int main()
{
int n;
int a,b;
while(cin>>n)
    {
    memset(g,0,sizeof(g));
    memset(h,0,sizeof(h));
    memset(bj,0,sizeof(bj));
    for(int i=1;i<=n;i++)
        {
        son[i].clear();
        v[i].clear();
        }
    for(int i=2;i<=n;i++)
        {
        scanf("%d%d",&a,&b);
        son[a].push_back(i);
        v[a].push_back(b);
        }
    dfs(1);
    dfs1(1);
    for(int i=1;i<=n;i++)
        cout<<max(bj[i],h[i])<<endl;
    }
return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值