HUD-4925-Apple Tree

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1407    Accepted Submission(s): 839


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
  
  
2 2 2 3 3
 

Sample Output
  
  
8 32

题意:吃苹果,然后最多走m步。简单说就是从根节点出发走m步所能获得的最大价值。

简单题就不解释了,不过感觉当时用的word例题上的代码不够简洁。。。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<math.h>
using namespace std;
int n,k;
int v[105];
vector<int>tree[105];
int dp[105][205][2];
void dfs(int p,int before)
{
for(int i=0;i<tree[p].size();i++)
    {
    int next=tree[p][i];
    if(next==before)
        continue;
    dfs(next,p);
    for(int j=k;j>=1;j--)
        {
        for(int z=1;z<=j;z++)
            {
            dp[p][j][0]=max(dp[p][j][0],dp[p][j-z][1]+dp[next][z-1][0]);
            dp[p][j][0]=max(dp[p][j][0],dp[p][j-z][0]+dp[next][z-2][1]);
            dp[p][j][1]=max(dp[p][j][1],dp[p][j-z][1]+dp[next][z-2][1]);
            }
        }
    }
}
int main()
{
int fa,son;
while(cin>>n>>k)
    {
    for(int i=0;i<105;i++)
        tree[i].clear();
    for(int i=1;i<=n;i++)
        {
        scanf("%d",&v[i]);
        for(int j=0;j<=k;j++)
            dp[i][j][0]=dp[i][j][1]=v[i];
        }
    for(int i=0;i<n-1;i++)
        {
        scanf("%d%d",&fa,&son);
        tree[fa].push_back(son);
        tree[son].push_back(fa);
        }
    dfs(1,0);
    cout<<max(dp[1][k][0],dp[1][k][1])<<endl;
    }
return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值