POJ-2378-Tree cutting

Tree Cutting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4901 Accepted: 3007

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N.

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS:

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

Source

题意:删除树中一个点,得到的子树中节点最多的节点数要小于等于总节点数的一半。

当时刚做完Godfather,一看题意,这不是一模一样么,就是条件不一样,高高兴兴直接改了输出就提交了,然后PE,哎,就是不能高兴的太早,改下输出,一行一个就行了,ac。

#include<iostream>
#include<string.h>
#include<math.h>
#include<stdio.h>
using namespace std;
int p;
int head[100005];
struct f
{
int now,next;
}tree[100005];
int bj[50005],s[50005];
void build(int a,int b)
{
tree[p].now=b;
tree[p].next=head[a];
head[a]=p;
p++;
}
void dfs(int a,int b)
{
int nnext;
for(int i=head[a];i!=-1;i=tree[i].next)
    {
    nnext=tree[i].now;
    if(nnext!=b)
        {
        dfs(nnext,a);
        bj[a]+=bj[nnext];
        }
    }
}
void dfs2(int a,int b)
{
int nnext;
for(int i=head[a];i!=-1;i=tree[i].next)
    {
    nnext=tree[i].now;
    s[a]=max(bj[nnext],s[a]);
    if(nnext!=b)
        {
        int x=bj[a];
        int y=bj[nnext];
        bj[a]=x-y;
        bj[nnext]=x;
        dfs2(nnext,a);
        bj[a]=x;
        bj[nnext]=y;
        }
    }
}
int main()
{
int n,a,b;
while(cin>>n)
    {
    memset(head,-1,sizeof(head));
    p=0;
    for(int i=1;i<n;i++)
        {
        scanf("%d%d",&a,&b);
        build(a,b);
        build(b,a);
        bj[i]=1;
        }
    bj[n]=1;
    dfs(1,-1);
    dfs2(1,-1);
    int ans=999999999;
    for(int i=1;i<=n;i++)
        ans=min(ans,s[i]);
    for(int i=1;i<=n;i++)
        if(s[i]<=n/2)
            cout<<i<<endl;
    }
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值