POJ-3140-Contestants Division

Contestants Division
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10926 Accepted: 3058

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source

题意:求删除一个点后的形成的两个子树的节点的差值。

因为是二叉树嘛更好做了,求出一个子树的节点数,然后差值就是|总结点数-2*任一子树节点数目|。

代码:

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<vector>
using namespace std;
int n,m;
vector<int>tree[100005];
int v[100005];
long long minn,s;
void csh()
{
for(int i=0;i<=n;i++)
    tree[i].clear();
minn=9223372036854775807;
s=0;
}
void build(int fa,int son)
{
fa--;
son--;
tree[fa].push_back(son);
tree[son].push_back(fa);
}
long long dfs(int pp,int to)
{
long long ans=0;
long long sum=0;
for(int i=0;i<tree[pp].size();i++)
    {
    if(tree[pp][i]==to)
        continue;
    long long ss=tree[pp][i];
    ans=dfs(ss,pp);
    long long c=s-2*ans;
    if(c<0)
        c*=-1;
    if(minn>c)
        minn=c;
    sum+=ans;
    }
return sum+v[pp];
}
int main()
{
int j=1,a,b;
while(cin>>n>>m&&n+m)
    {
    csh();
    for(int i=0;i<n;i++)
        {
        scanf("%d",&v[i]);
        s+=v[i];
        }
    for(int i=0;i<m;i++)
        {
        scanf("%d%d",&a,&b);
        build(a,b);
        }
    dfs(0,-1);
    cout<<"Case "<<j++<<": ";
    cout<<minn<<endl;
    }
return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值