杭电 2057 A + B Again

25 篇文章 0 订阅
19 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2057
Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

其实就是十六进制的加减。不过以前没遇到过这么大的

#include<iostream>
#include<sstream>
#include<cstring>
#include<algorithm>
#include<set>
#include<cstdio>
using namespace std;
int main(){
    __int64 a,b;
    while(scanf("%I64X %I64X",&a,&b)!=EOF){
        if(a+b>=0){
            printf("%I64X\n",a+b);
        }
        else{   //第一次用到这么大的数据类型,很奇怪,为负数时非要这么写  路过的大佬方便的话解个答 
            printf("-%I64X\n",-a-b);//这里的x要大写,这样结果输出的格式才会大写 
        }
    } 
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值