hdu6055Regular polygon

Regular polygon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 579    Accepted Submission(s): 219


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
  
  
1 2
 

/*
		题解:容易得知只有正四边形可以使得所有的顶点为整数点。
		(具体证明可参考杨景钦在2017的国家队论文) 所以正解即求出所有的正四边形个数。
        枚举2个点,然后暴力判断另外2个点的位置是否存在。
*/
#include <bits/stdc++.h>
#define ll long long
#define N 2000
using namespace std;
int point[N][N];
struct node{
    int x,y;
}a[N];
bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int n;
    while(~scanf("%d",&n)) {
        int x[N],y[N];
        memset(point,0,sizeof(point));
        for(int i=0;i<n;i++) {
            scanf("%d%d",&a[i].x,&a[i].y);
            point[a[i].x+10][a[i].y+10]=1;
        }
        int ans=0;
        //sort(a,a+n,cmp);
        for(int i=0;i<n;i++) {
            for(int j=i+1;j<n;j++) {
                //以两个点作为边长找到成九十度角位置的方向点的位置是否存在
                int dx=a[j].y-a[i].y;
                int dy=a[i].x-a[j].x;
                int count=0;
                if(point[a[i].x+10+dx][a[i].y+10+dy])
                    count++;
                if(point[a[j].x+10+dx][a[j].y+10+dy])
                    count++;
                if(count==2)
                    ans++;
                count=0;
                if(point[a[i].x+10-dx][a[i].y+10-dy])
                    count++;
                if(point[a[j].x+10-dx][a[j].y+10-dy])
                    count++;
                if(count==2)
                    ans++;
            }
        }
        printf("%d\n",ans>>2);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值