hdu 1158 Employment Planning

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5818    Accepted Submission(s): 2536


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
 
 
3 4 5 6 10 9 11 0
 

Sample Output
 
 
199
题目链接: 点击打开链接

 题解:输入第一行是项目数
          第二行分别是雇佣一个人,每个人一个月薪水,解雇一个人用的钱
          第三行每个项目需要雇佣的最少人数。求完成每个项目所需最少的钱
          dp[i][j] 表示第i项目雇佣j个人时所用最小金币
          因为dp[i-1]每一项都影响dp[i][j],所以需要枚举dp[i-1][k];
          dp[i][j] = min(dp[i][j], dp[i-1][k]+sum),num[i] <= j <= maxi, num[i-1] <= k <= maxi
 

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define N 21000
int dp[20][N], num[N];
int hire, fire, salary;
int main()
{
	int n;
	while(scanf("%d", &n)!=EOF, n) {
		scanf("%d%d%d", &hire, &salary, &fire);
		int maxi = -INF;
		memset(dp, INF ,sizeof(dp));
		for(int i = 1; i <= n; i++) {
			scanf("%d", &num[i]);
			maxi = max(maxi, num[i]);
		}
		for(int j =  num[1]; j <= maxi; j++)
			dp[1][j] = j*(salary+hire);
		for(int i = 2; i <= n; i++) {
			for(int j = num[i]; j <= maxi; j++) {
                int mini = INF;
				for(int k = num[i-1]; k <= maxi; k++) {
					int sum = 0;
					if(k >= j)
						sum = j*salary + (k-j)*fire;
					else
						sum = j*salary + (j-k)*hire;
					dp[i][j] = min(dp[i][j], dp[i-1][k] + sum);
				}
			}
		}
		int ans = INF;
		for(int i = num[n]; i <= maxi; i++)
			ans = min(ans,dp[n][i]);
		printf("%d\n", ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值