hdu 1024 Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33937    Accepted Submission(s): 12092


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
 
1 3 1 2 32 6 -1 4 -2 3 -2 3
 

Sample Output
 
 
68
Hint
Huge input, scanf and dynamic programming is recommended.

/*
求最大M字段
dp[i][j]表示第i段前j个元素产生的最大和
dp[i][j] = max(dp[i][j-1]+a[j], {dp[i-1][k]+a[j]})(i-1<=k<j}(i<=j<=n)实际j要<=n-m+i
dp[i][j-1]+a[j]表示的是前j-1分成i组,第j个必须放在前一组里面。
max( dp[i-1][k] ) + a[j] )表示的前(0<k<j)分成i-1组,第j个单独分成一组。
 */
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define N 1100000
int n, m;
long long dp[2][N];
long long a[N];
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &m, &n) != EOF) {
		for(int i = 1; i <= n; i++) {
			scanf("%lld", &a[i]);
			dp[0][i] = dp[1][i] = 0;
		}
		int  t = 1;
		for(int i = 1; i <= m; i++) {
			dp[t][i] = dp[1-t][i-1]+a[i];
			long long maxi =  dp[1-t][i-1];
			for(int j = i+1; j <= n; j++) {
				maxi = max(dp[1-t][j-1], maxi);
				dp[t][j] = max(dp[t][j-1], maxi) + a[j];
			}
			t = 1-t;	//将本行转换成上一行
		}
		t = 1-t;
		long long maxi = -200000000000000;
		//printf("%lld\n",maxi);
		for(int i = m; i <= n; i++) {   //从m到n因为至少分成m段
			maxi = max(maxi, dp[t][i]);
		}
		printf("%lld\n", maxi);
	}
	return 0;
}

.滚动数组的另一种表达:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define N 1100000
int n, m;
long long dp[2][N];
long long a[N];
int main(int argc, char const *argv[])
{
    while(scanf("%d%d", &m, &n) != EOF) {
        for(int i = 1; i <= n; i++) {
            scanf("%lld", &a[i]);
            dp[0][i] = dp[1][i] = 0;
        }
        for(int i = 1; i <= m; i++) {
            dp[i%2][i] = dp[(i-1)%2][i-1]+a[i];
            long long maxi =  dp[(i-1)%2][i-1];
            for(int j = i+1; j <= n; j++) {
                maxi = max(dp[(i-1)%2][j-1], maxi);
                dp[i%2][j] = max(dp[i%2][j-1], maxi) + a[j];
            }

        }

        long long maxi = -200000000000000;
        //printf("%lld\n",maxi);
        for(int i = m; i <= n; i++) {
            maxi = max(maxi, dp[m%2][i]);
        }
        printf("%lld\n", maxi);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值