1028. 人口普查(20)

1028. 人口普查(20)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John

没能完全AC,望指正

#include<iostream>
#include<map>
#include<cstdio>
using namespace std;
int ruler(string s){
	int year=0,month=0,day=0;
	string end = "2014/09/06" , star = "1814/09/06";
	year = (s[0]-'0')*1000+(s[1]-'0')*100+(s[2]-'0')*10+s[3]-'0';
	month = (s[5]-'0')*10+s[6]-'0';
	day = (s[8]-'0')*10+s[9]-'0';	 
	if (month>12||month<1)  //月份>12或<1 
		return 0;
	if (month==1||month==3||month==5||month==7||month==8||month==10||month==12){  //这些月份天数不能31 
		if (day>31)
			return 0;
		else{																//剩余月份天数不能大于30 
			if (day>30)
				return 0;
			}
	}
	if (year%400==0||year%4==0&&year%100!=0){			//为闰年,2月不能大于 29 
		if (month==2){
			if (day>29)
			return 0;
		}
	else{												//平年,2月不能大于28		
		if (month==2)
			if (day>28)
			return 0;
		}
	}
	if (s>=star&&s<=end)
		return 1;
	return 0;
}
int main(){
	string name,date;
	long long  n,p=0;
	cin>>n;
	map<string,string> m;
	for (int i=0;i<n;i++){
		cin>>name>>date;
		if (ruler(date))
		{
		m[date] = name;
			p++;
		}
	}

	cout<<p<<" ";

        cout<<m.begin()->second<<" "<<m.rbegin()->second<<endl;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值