hdoj Work

点击打开链接

                                        Work



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Output
For each test case, output the answer as described above.
Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7
Sample Output
2
题解:这是并查集的题目,大意就是找领导者和员工之间的关系

下面是我的代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX=1e3+10;
int par[MAX],num[MAX];

void find(int m)
{
	if(par[m]!=m)
	{
		num[par[m]]++;//记录 每个上级所带领的下属个数 
		find(par[m]);
		return ;
	}
	
}

void un(int x,int y)
{
	if(x!=y)
	par[y]=x;
}

int main()
{
	int n,m,ans;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int a,b;
		memset(num,0,sizeof(num));
		for(int i=1;i<=n;i++)
			par[i]=i;
		
		for(int j=1;j<n;j++)
		{
			scanf("%d%d",&a,&b);
			un(a,b);

		}
		for(int i=1;i<=n;i++)
		find(i);//寻找每个点的下属个数 
		ans=0;
		for(int i=1;i<=n;i++)
		{
			if(num[i]==m)
			ans++;
		}
		printf("%d\n",ans);	
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值