【openjudge】Maximum sum

1481:Maximum sum

Total time limit: 1000ms
memory limit: 65536kB
如果有想看中文版的同学,轻击中文版,如果有想看源代码的同学,轻击源代码

describe

Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

                     t1     t2 
         d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
                    i=s1   j=s2

Your task is to calculate d(A).

input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.

output

Print exactly one line for each test case. The line should contain the integer d(A).

sample input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

sample output

13

Prompt

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

source

POJ Contest,Author:Mathematica@ZSU

【analysis】+【Code】

状态: Accepted

#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,nmax,a[50001],f[50001],g[50001],F[50001],G[50001];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        nmax=-10001;
        cin>>n>>a[1];
        int mxf=F[1]=f[1]=a[1];//统一开头
        for(int i=2;i<=n;i++)//两段for,分别从前后检查
        {
            cin>>a[i];
            f[i]=a[i]+max(0,f[i-1]);//加上前面一个的数,如果是负数,就不加
            mxf=F[i]=max(mxf,f[i]);//储存最大f[]
        }
        int mxg=G[n]=g[n]=a[n];//统一g[]结尾   
        for(int i=n-1;i>0;i--)//不能包含n
        {
            g[i]=a[i]+max(0,g[i+1]);//储存最大(加上后一个数(如果不为负))
            G[i]=max(mxg,g[i]);
            mxg=G[i];
        }
        for(int i=1;i<n;i++)
            if(F[i]+G[i+1]>nmax)
                nmax=F[i]+G[i+1];
        cout<<nmax<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值