[八中测试]AtCoder ABC093

本文详细解析了AtCoder ABC093竞赛中的四道题目,包括'A'题的字符串排列验证,'B'题的大小整数筛选,'C'题的同值整数最少操作次数,以及'E'题的糖果分配问题。每道题目都提供了问题陈述、约束条件、输入输出示例以及最优解法的思路和AC代码。
摘要由CSDN通过智能技术生成

A - abc of ABC

Problem Statement

You are given a string S of length 3 consisting of a, b and c. Determine if S can be obtained by permuting abc.

Constraints

|S|=3
S consists of a, b and c.
Input
Input is given from Standard Input in the following format:

S

Output

If S can be obtained by permuting abc, print Yes; otherwise, print No.

Sample Input 1

bac

Sample Output 1

Yes

Swapping the first and second characters in bac results in abc.

Sample Input 2

bab

Sample Output 2

No

Sample Input 3

abc

Sample Output 3

Yes

Sample Input 4

aaa

Sample Output 4

No

【解析】

第一题应该很好理解,也应该很快可以完成,就是一个暴力判定,就完。

AC代码:

#include<cstdio>
#define N 6
char s[N];
bool f[N];
int main()
{
    scanf("%s",s);
    for(int i=0;i<3;i++)
    f[int(s[i]-97)]=1;
    if(f[0]&&f[1]&&f[2]) printf("Yes\n");
    else printf("No\n");
}
----------------------------------------------------------------
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值