Colorful Subsequence

Colorful Subsequence

题目描述

You are given a string S of length N. Among its subsequences, count the ones such that all characters are different, modulo 109+7. Two subsequences are considered different if their characters come from different positions in the string, even if they are the same as strings.

Here, a subsequence of a string is a concatenation of one or more characters from the string without changing the order.

Constraints
·1≤N≤100000
·S consists of lowercase English letters.
·|S|=N

输入

Input is given from Standard Input in the following format:

N
S

输出

Print the number of the subsequences such that all characters are different, modulo 109+7.

样例输入

4
abcd
样例输出
15
提示

Since all characters in S itself are different, all its subsequences satisfy the condition.

ps:这个题有点小坑。字串所有字符都要不同。所以最多26个字符。不同位置算不同。所以把26个字符每个字符的位置(数量)统计出来,+1,连乘。再-1;、


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include <iostream>

#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

 

const ll mod = 1e9+7;

 

int a[26];

int main(int argc, char *argv[])

{

    int n;

    cin>>n;

    string s;

    cin>>s;

    for(int i=0;i<s.length();i++){

        a[s[i]-'a']++;

    }

    ll ans=1;

    for(int i=0;i<26;i++){

        ans=ans*ll(a[i]+1)%mod;

    }

    cout<<ans-1<<endl;

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值