HDU 2689 Sort it【树状数组求逆序对】

Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3

1 2 3

4

4 3 2 1

Sample Output

0

6

题解:倒着求,每次统计 a[i]后边有多少个比它小,同时更新a[i]出现的次数。(树状数组维护的是前缀和......牢记)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1005;
int n;
int a[maxn], c[maxn];
int lowbit(int x) {
    return x & -x;
}
int get_sum(int x){
    int sum = 0;
    while(x){
        sum += c[x];
        x -= lowbit(x);
    }
    return sum;
}
void add(int x, int val) {
    while(x <= n){
        c[x] += val;
        x += lowbit(x);
    }
}
int main()
{
    while(~scanf("%d", &n)){
        memset(c, 0, sizeof c);
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        int ans = 0;
        for(int i = n; i >= 1; i--){//倒序统计
            ans += get_sum(a[i] - 1);//查询a[i]后边有多少个数比它小
            add(a[i], 1);//a[i]出现的次数+1
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值