HDU 2689 Sort it(树状数组求逆序数)

Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3418    Accepted Submission(s): 2478


Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
  
  
3 1 2 3 4 4 3 2 1
 

Sample Output
  
  
0 6
 

Author
WhereIsHeroFrom
 

Source




题意,用冒泡排序的方法把n个数排成按升序排列需要几步。





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 1001;

int n;
int num[N];
int c[N];
struct node{
    int x;
    int id;
}q[N] ;

bool cmp(node a,node b){
    return a.x < b.x;
}

int lowbit(int x){
    return x&(-x);
}

int getsum(int x){
    int s = 0;
    while(x>0){
        s += c[x];
        x -= lowbit(x);
    }
    return s;
}

void add(int x,int y){
    while(x<=n){
        c[x] += y;
        x += lowbit(x);
    }
}

int main()
{
    while(scanf("%d",&n)!=EOF){
        memset(c,0,sizeof(c));
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++){
            scanf("%d",&q[i].x);
            q[i].id = i;
        }
        sort(q+1,q+1+n,cmp);
        for(int i=1;i<=n;i++){
            num[q[i].id] = i;
        }
        int sum = 0;
        for(int i=1;i<=n;i++){
            add(num[i],1);
            sum += getsum(n) - getsum(num[i]);
        }
        printf("%d\n",sum);
    }
    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值