ZOJ 3261 Connections in Galaxy War ( 反向并查集)

题意:

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

 

Input

 

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains Nintegers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N- 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

 

Output

 

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

 

Sample Input

 

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

 

Sample Output

 

1
-1
-1
-1

思路:很显然并查集,但是,是删边操作,而并查集只能解决加边的操作,也没有要求在线操作,那么,就可以离线,从最终状态开始做,往前推,当作加边做。存下答案,最后输出就可以了。

就是所有输入都要先存起来,再倒着做,翻来覆去,有点繁琐,但是倒不难

不过,这个有点讨厌的地方就是,每两组数据之间要输出一个空行,但是最后不能多输出空行,不然PE。。。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<cmath>
using namespace std;
typedef long long ll;
int n,m,q,a[10005],num,f[10005],l,r,ans[50005];
struct AA
{
    char ch[10];
    int a,b;
    bool operator<(const AA aa)const
    {
        if(a==aa.a) return b<aa.b;
        return a<aa.a;
    }
    bool operator==(const AA aa)const
    {
        return b<aa.b&&a<aa.a;
    }
}pos[20005],del[50005];
int fin(int i)
{
    return (i==f[i])?i:f[i]=fin(f[i]);
}
int main()
{
    map<AA,int>ma;
    int t=0;
    while(~scanf("%d",&n))
    {
        if(t++) printf("\n");///题目要求两组数据间输出空号,最后一组后面不能输出,不然PE。。
        ma.clear();
        num=0;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]),f[i]=i;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&pos[i].a,&pos[i].b);
            if(pos[i].a>pos[i].b) swap(pos[i].a,pos[i].b);
        }
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%s",del[i].ch);
            if(del[i].ch[0]=='q')
                scanf("%d",&del[i].a);
            else
            {
                scanf("%d%d",&del[i].a,&del[i].b);
                if(del[i].a>del[i].b) swap(del[i].a,del[i].b);
                ma[del[i]]=1;
            }
        }
        for(int i=1;i<=m;i++)
        {
            if(ma[pos[i]]) continue;
            l=fin(pos[i].a);
            r=fin(pos[i].b);
            if(l==r) continue;
            if(a[l]==a[r])
            {
                if(l>r) swap(l,r);
                f[r]=l;
            }
            else if(a[l]>a[r])
            {
                f[r]=l;
            }
            else f[l]=r;
        }
        for(int i=q;i>=1;i--)
        {
            if(del[i].ch[0]=='d')
            {
                l=fin(del[i].a);
                r=fin(del[i].b);
                if(l==r) continue;
                if(a[l]==a[r])
                {
                    if(l>r) swap(l,r);
                    f[r]=l;
                }
                else if(a[l]>a[r])
                {
                    f[r]=l;
                }
                else f[l]=r;
            }
            else
            {
                l=fin(del[i].a);
                if(a[l]<=a[del[i].a])
                    ans[++num]=-1;
                else ans[++num]=l;
            }
        }
        for(int i=num;i>=1;i--)
        {
            printf("%d\n",ans[i]);
        }
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值