poj-1338 Ugly Numbers(类似筛素数)

题意:

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

思路:类似晒素数,放了两种做法

代码:(AC)

#include<iostream>
#include<cstdio>
#include<set>
using namespace std;
#define mod 100007
set<long long>s;
set<long long>::iterator it;
long long a[1510],b[1510],x,y,z;
int cnt;
int main()
{
    b[1]=1;
    x=y=z=1;
    for(int i=2;i<=1500;i++)
    {
        b[i]=min(min(b[x]*2,b[y]*3),b[z]*5);
        if(b[i]==b[x]*2) x++;
        if(b[i]==b[y]*3) y++;
        if(b[i]==b[z]*5) z++;
    }
    int n;
    s.insert(1);
    cnt=0;
    while(!s.empty())
    {
        it=s.begin();
        a[++cnt]=*it;//cout<<cnt<<" "<<a[cnt]<<" "<<y<<endl;
        s.erase(s.begin());

        if(cnt==1500) break;
        x=a[cnt];
        y=x*2;
        s.insert(y);
        y=x*3;
        s.insert(y);
        y=x*5;
        s.insert(y);

    }
   while(~scanf("%d",&n)
{printf("%d\n",b[n]);
}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值