容斥原理dfs

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9807    Accepted Submission(s): 2943


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
 
 
12 2 2 3
 

Sample Output 
7
Author
wangye
 

Source

    题意:给定n和一个大小为m的集合,集合元素为非负整数,求1~n中能被集合里任意一个数整除的数的个数。

   思路:容斥原理的应用。先找出1-n中能被集合中任意一个数整除的数的个数,再减去能被集合中任意两个数整除的数的个数,即能被他们两个最小公倍数整除的数的个数···,奇加偶减

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<math.h>
#include<algorithm>
#include<stack>
using namespace std;
typedef long long ll;
int n,m,cnt;
ll ans,a[30];
ll gcd(ll a,ll b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
void dfs(int cur,ll lcm,int id)
{
    lcm=a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)
        ans+=(n-1)/lcm;//因为此题并不包括n本身
    else
        ans-=(n-1)/lcm;
    for(int i=cur+1;i<cnt;i++)
        dfs(i,lcm,id+1);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cnt=0;
        int x;
        while(m--)
        {
            scanf("%d",&x);
            if(x)
                a[cnt++]=x;
        }
        ans=0;
        for(int i=0;i<cnt;i++)
            dfs(i,a[i],1);
        cout<<ans<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值