前缀后缀gcd 2017 ccpc女生专场 1003 Coprime Sequence

Do you know what is called ``Coprime Sequence''? That is a sequence consists of  nnpositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
InputThe first line of the input contains an integer  T(1T10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer  n(3n100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of  nn integers  a1,a2,...,an(1ai109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.OutputFor each test case, print a single line containing a single integer, denoting the maximum GCD.Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2
2

题意:给你一个序列,求去掉一个数后剩余数的最大公约数的最大值。

暴力果断TLE,TLE的原因是删一个数就求一遍剩余数的gcd,一定超时。

类似于前缀和后缀和,求前缀gcd和后缀gcd

对于某个位置上的数i,其左边数([1,i-1])的gcd是x1,右边数([i+1,n])的gcd是x2,那么删掉ai后剩余数的gcd是(gcd(x1,x2))。

(求n个数的gcd先求哪两个数都可以)

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<math.h>
#include<algorithm>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=100005;
int a[maxn];
int gcd1[maxn],gcd2[maxn];//正着来一遍,反着来一遍;
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        gcd1[0]=gcd2[n+1]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i==1) gcd1[i]=a[i];
            else  gcd1[i]=__gcd(gcd1[i-1],a[i]);
        }

        for(int i=n;i>=1;i--)
        {
            if(i==n) gcd2[i]=a[i];
            else gcd2[i]=__gcd(gcd2[i+1],a[i]);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,__gcd(gcd1[i-1],gcd2[i+1]));
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值