PAT 甲级 1024. Palindromic Number

1024. Palindromic Number (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

题目大意:给你一个n和一个k,这个n反转以后与原来的数相加能否得到一个在K步内得到一个回文数,如果能就输出步数和数字,不能的话就输出k和数字

这道题好坑.....原来如果输入的数字本身就是回文数的话,他的步数是0.......

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
using namespace std;
string add(string &a,string &b){
	//cout<<"*******"<<a<<' '<<b<<endl;
	string tmp;
	int carry=0;
	for(int i=a.size()-1;i>=0;i--){
		tmp.insert(tmp.begin(),((a[i]-'0')+(b[i]-'0')+carry)%10+'0');
		carry=((a[i]-'0')+(b[i]-'0')+carry)/10;
	}
	if(carry) tmp.insert(tmp.begin(),carry+'0');
	return tmp;
}
int main(){
	//freopen("in.txt","r",stdin);
	string str,tmp;
	int step;
	cin>>str>>step;
	int i;
	for(i=0;i<step;i++){
		tmp=str;
		reverse(tmp.begin(),tmp.end());
		if(tmp==str){
			cout<<str<<endl<<i<<endl;
			break;
		}
		else{
			str=add(str,tmp);
		}
	}
	if(i>=step) cout<<str<<endl<<step<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值