PAT 甲级 1024 (Palindromic Number)

题目要求

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤ 1 0 10 10^{10} 1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

翻译

输入一个数和最大步数,每一步计算该数和倒转数的和,判断是否为回文数,如果不是则继续相加,直到最大步数用完,还不是的话就输出这时候的和和最大步数

代码

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
string n;
int k;

string reverse(string str)
{
    string s;
    for(int i=str.size()-1;i>=0;i--)
    {
        s+=str[i];
    }
    return s;
}
string add(string a, string b)
{
	reverse(a.begin(), a.end());
	reverse(b.begin(), b.end());
	int len = a.size() + b.size() + 10;
	int t = 0;
	string ans(len, '0');
	for (int i = 0; i < a.size(); i++)
	{
		ans[i] = a[i];
	}
	for (int i = 0; i < len; i++)
	{
		if (i < b.size())
		{
			t += (ans[i] - '0') + (b[i] - '0');
		}
		else
		{
			t += ans[i] - '0';
		}
		ans[i] = t % 10 + '0';
		t /= 10;
	}
	reverse(ans.begin(), ans.end());
	return ans.substr(ans.find_first_not_of('0'));
}
bool judge(string num)
{
    for(int i=0;i<num.size()/2;i++)
    {
        if(num[i]!=num[num.size()-1-i]) return false;
    }
    return true;
}
int main()
{
    cin>>n>>k;
    string s,sum=n;
    if(judge(sum)){
        cout<<sum<<endl;
        cout<<"0"<<endl;
        return 0;
    }
    for(int i=1;i<=k;i++)
    {
        s = reverse(sum);
        sum = add(sum,s);
        if(judge(sum)) {
            cout<<sum<<endl;
            cout<<i<<endl;
            return 0;
        }
    }
    cout<<sum<<endl;
    cout<<k<<endl;
    system("pause");
}

思路

我的步骤写的中规中矩,完全没有任何的省略,先是对string的倒转,再是对两数模拟相加,再是判断是否为回文。按照题目的逻辑往下套用写的函数即可。
值得注意的是测试点2、3,如果一开始输入的就是回文,则直接输出这个数和0.

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值