HDU 5924 Mr. Frog’s Problem

Mr. Frog’s Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1504    Accepted Submission(s): 869


Problem Description
One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that  ACB,ADB  and  AB+BACD+DC
 

Input
first line contains only one integer T ( T125 ), which indicates the number of test cases. Each test case contains two integers A and B ( 1AB1018 ).
 

Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1). 

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.
 

Sample Input
  
  
2 10 10 9 27
 

Sample Output
  
  
Case #1: 1 10 10 Case #2: 2 9 27 27 9
 

Source
 

写这道题的时候感觉输出样例有些奇怪,感觉是不是有规律,就写了一发,竟然过了.......

这里有证明:点击打开链接

#include<iostream>
using namespace std;
typedef long long ll;
int main(){
	int t;
	cin>>t;
	for(int i=1;i<=t;i++){
		ll a,b;
		cin>>a>>b;
		printf("Case #%d:\n",i);
		if(a==b){
			cout<<1<<endl;
			cout<<a<<' '<<b<<endl;
		}
		else{
			cout<<2<<endl;
			cout<<a<<' '<<b<<endl;
			cout<<b<<' '<<a<<endl;
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值