Graph Theory
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1966 Accepted Submission(s): 818
Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ..., n}. You have to consider every vertice from left to right (i.e. from vertice 2 to n). At vertice i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i−1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
Input
The first line of the input contains an integer T(1≤T≤50), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤100000) in the first line, denoting the number of vertices of the graph.
The following line contains n−1 integers a2,a3,...,an(1≤ai≤2), denoting the decision on each vertice.
Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
Sample Input
3 2 1 2 2 4 1 1 2
Sample Output
Yes No No
题目大意:给你n个点,每个点有两种选择,选1是当前这个点与它前面的每个点都连上一条边,选2是什么都不干,给出2到n个点的选择,问这个图是不是一个Cool Graph ,一个Cool Graph表示能选出一个边集,使得每一个点都只被一条边覆盖
贪心,从最开始遍历每一个点的选择,如果有一个点出现了1,就让它与前面没有边连的点连上
#include<iostream>
using namespace std;
const int maxn=1e5+7;
int num[maxn];
int main()
{
int test;
scanf("%d",&test);
while(test--)
{
int n;
scanf("%d",&n);
for(int i=2;i<=n;i++)
{
scanf("%d",&num[i]);
}
if(n&1) cout<<"No"<<endl;
else
{
int res=1;
for(int i=2;i<=n;i++)
{
res++;
if(num[i]==1&&res>=2)
{
res-=2;
}
}
if(res==0) cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
}
return 0;
}