L - 题(HDU1010)

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

深搜加奇偶剪枝,这是我第一次写剪枝,我对奇偶剪枝的印象是这样的,求出从A点到B点理论上的最少步数,记为T,然后求出你从A点到B点的步数,(本题的代码中)记为K,求出K-T,记为E,若E<0或者E是奇数,那么从A点无法在K步恰好到达B点

简而言之,就是额外步数是奇数或者额外步数小于0就无法恰好到达

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int m,n,k;
int x,y; //起始点
int xl,yl; //目标点
int T; //理论上最小的步数
bool flag; //是否找到目标点
char maze[10][10];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int vis[10][10];
void dfs(int i,int j,int step)
{
    if((k-step)<0||(k-T)&1) //额外步数小于0或者是奇数就无法在k步恰好到达,此时直接回退
      return;
    if(step==k&&maze[i][j]=='D')   //已经在k步恰好找到目标点
    {
        flag = true;
    }
    if(flag)
     return;
    for(int ii=0;ii<4;++ii)
    {
       int dx = dir[ii][0]+i;
       int dy = dir[ii][1]+j;
       if(dx>=0&&dx<m&&dy>=0&&dy<n&&maze[dx][dy]!='X'&&!vis[dx][dy])
       {
            vis[dx][dy]=1;
            dfs(dx,dy,step+1);  //走下一步
            vis[dx][dy]=0;
       }    
    }      
}
int main()
{
    while(~scanf("%d%d%d",&m,&n,&k))
    {
        if(!m&&!n&&!k)
         {
             break;
         }
        memset(vis,0,sizeof(vis));
        flag = false;
        for(int i=0;i<m;++i)
        {
            cin>>maze[i];
            for(int j=0;j<n;++j)
            {
                if(maze[i][j]=='S')
                {
                     x=i;
                     y=j;
                }
                else if(maze[i][j]=='D')
                {
                    xl=i;
                    yl=j;
                }
            }
        }
        T=abs(x-xl)+abs(y-yl); //理论上最小的步数就是A与B之间的横坐标差的绝对值加上纵坐标差的绝对值
        vis[x][y]=1;
        dfs(x,y,0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值